Sunday, December 11, 2011

Important AIX commands

lsitab init : to display default runlevel of an AIX system

cat /etc/.init.state 
: to get current runlevel of an AIX system


lslpp : display installed softwares on AIX

/usr/lib/errdemon : to start error login ( errpt ) in AIX

procwait -v : wait for a process and display status

procsig : list all signal action defined by processes

chuser fsize=-1 : to give permissions to create files over 2GB for a user.(-1=no limit)

lppchk -l : to verify that the symbolic links assoiciated with a file set are correct as indicated in the SWVPD.

shutdown -F : fast shutdown AIX system

shutdown -Fr : fast reboot AIX system

shutdown -Fm : reboot an AIX system to maintenance mode

telinit 2 : reboot an AIX system to normal mode

teleinit q : read nittab file

oslevel -s : display the currently installed service pack level in AIX

find /apps -print | backup -i -v -f /dev/rmt0 : copy the contents of /apps to tape in AIX

who : display currently logged users

ln -sf /usr/lib/boot/unix_64 /unix
ln -sf /usr/lib/boot/unix_64 /usr/lib/boot/unix
bosboot -ad /dev/ipldevice
shutdown -Fr
 : reconfigure an AIX system from a 32-bit kernel to a 64-bit kernal.

oslevel -rl 5300-06 : show which filesets still need to get new technology level 5300-06 after AIX upgradation

chnfs -n 100 -B : increase the number of system threads allowed to access NFS mounts to 100

./myscript > /tmp/myoutput 2>1 : run myscript and redirect stdoutand stderr to /tmp/myoutput


installp -C : to cleanup improperly applied filesets ( interrupted)

lppchk -c : to verify all the filesets installed completely

lppchk -v : verify that the operating system(AIX) is in a consistent state after installing AIX technology level ( to verify all filesets are installed completely)

refresh -s inetd : to restart TCP/IP

chvg -Qn testvg : disable quorum in testvg

smit update_all : to apply system to latest technologic level from CD.

migratepv -l /dev/testlv hdisk1 hdisk2 : move (migrate) testlv from hdisk1 to hdisk2

migratepv hdisk1 hdisk2 : move all data from hdisk1 to hdisk2

lsfs -q /testfs : to check the size of /testfs and the LV mounted on it. i.e how much space required by the FS to reach as that to LV in it.

last    To list all the records in the /var/adm/wtmp file (all successful logins)




last shutdown         To show the time of previous shutdown of server.


last reboot    To show the time of previous reboot of server.  




uptime   To show how long the system has been up ( w -u )


oslevel                To list the operating system level


lslicense              To see the number of license


chlicense -u30          To change the fixed user license to 30


chlicense -f  on         To enable floating user license

lsmcode        To check system firmware version (sys0) 

invscout        To get firmware of all peripheral devices. It will generate the output in /var/adm/invscout/invs.mrp containing the firmwares of all peripheral devices.