Monday, December 19, 2011

AIX PAGING SPACE


# lsps -a
Page Space      Physical Volume   Volume Group    Size %Used Active  Auto  Type
hd6             hdisk0            rootvg         512MB    17   yes   yes    lv
CREATE A NEW LV TO USE FOR PAGING SPACE 

# mklv -t paging rootvg 5
pagelv00

SEE CURRENT PAGING SPACES WHICH ARE  REGISTERED 

#
# cat /etc/swapspaces
* /etc/swapspaces
*
* This file lists all the paging spaces that are automatically put into
* service on each system restart (the 'swapon -a' command executed from
* /etc/rc swaps on every device listed here).
*
* WARNING: Only paging space devices should be listed here.
*
* This file is modified by the chps, mkps and rmps commands and referenced
* by the lsps and swapon commands.
hd6:
        dev = /dev/hd6


ENABLING A PAGING SPACE 


# swapon /dev/pagelv00
# lsps -a
Page Space      Physical Volume   Volume Group    Size %Used Active  Auto  Type
pagelv00        hdisk0            rootvg         640MB     1   yes    no    lv
hd6             hdisk0            rootvg         512MB    17   yes   yes    lv
#
DISABLING A PAGING SPACE 


# swapoff /dev/pagelv00
# lsps -a
Page Space      Physical Volume   Volume Group    Size %Used Active  Auto  Type
pagelv00        hdisk0            rootvg         640MB     0    no    no    lv
hd6             hdisk0            rootvg         512MB    17   yes   yes    lv
#
CREATING A PAGING SPACE THROUGH mkps 


# mkps -a -n -s3 rootvg
paging00
# lsps -a
Page Space      Physical Volume   Volume Group    Size %Used Active  Auto  Type
paging00        hdisk0            rootvg         384MB     1   yes   yes    lv
pagelv00        hdisk0            rootvg         640MB     0    no    no    lv
hd6             hdisk0            rootvg         512MB    17   yes   yes    lv
MKPS AUTOMATICALLY ADDS PAGING SPACE IN /etc/swapspaces 


# cat /etc/swapspaces
* /etc/swapspaces
*
* This file lists all the paging spaces that are automatically put into
* service on each system restart (the 'swapon -a' command executed from
* /etc/rc swaps on every device listed here).
*
* WARNING: Only paging space devices should be listed here.
*
* This file is modified by the chps, mkps and rmps commands and referenced
* by the lsps and swapon commands.
hd6:
        dev = /dev/hd6


paging00:
        dev = /dev/paging00

CHANGING PAGING SPACE 

INCREASING PAGING SIZE 

# lsps -a
Page Space      Physical Volume   Volume Group    Size %Used Active  Auto  Type
paging00        hdisk0            rootvg         384MB     1   yes   yes    lv
pagelv00        hdisk0            rootvg         640MB     0    no    no    lv
hd6             hdisk0            rootvg         512MB    17   yes   yes    lv


# chps -s 2 paging00


# lsps -a
Page Space      Physical Volume   Volume Group    Size %Used Active  Auto  Type
paging00        hdisk0            rootvg         640MB     1   yes   yes    lv
pagelv00        hdisk0            rootvg         640MB     0    no    no    lv
hd6             hdisk0            rootvg         512MB    17   yes   yes    lv
#
DECREASING PAGING SPACE 


# chps -d 1 paging00
shrinkps: Temporary paging space paging01 created.
shrinkps: Paging space paging00 removed.
shrinkps: Paging space paging00 recreated with new size.


# lsps -a
Page Space      Physical Volume   Volume Group    Size %Used Active  Auto  Type
paging00        hdisk0            rootvg         512MB     1   yes   yes    lv
pagelv00        hdisk0            rootvg         640MB     0    no    no    lv
hd6             hdisk0            rootvg         512MB    17   yes   yes    lv
#