Thursday, August 19, 2010

Some small interview Questions

Q: How do you display your running kernel version? (Solaris, AIX, Linux)
A: Linux # uname –r , Solaris # showrev

Q: Which command do you use to display a table of running processes? (Solaris, AIX, Linux)
A: Linux # ps –ef and top , Solaris # prstat

Q: Which file do you modify to configure a domain name resolver? (Solaris, AIX, Linux)
A: Linux # /etc/resolv.conf , Solaris # /etc/resolv.conf

Q: Which file contains a list of locally defined hostnames and corresponding IP addresses? (Solaris, AIX, Linux)
A: Linux # /etc/hosts , Solaris # /etc/hosts and linked file /etc/inet/hosts

Q: How do you display a routing table? (Solaris, AIX, Linux)
A: Linux # ip route show or #netstat –nr or #route –n and Solaris # netstat –nr and #route -n

Q: Which command would you use to view partitions and their sizes on Solaris?
A: # df -kh

Q: Which OpenBoot command would you use to print/view OpenBoot environment variables on a SUN server?
A: #printenv

Q: What does ”ypwhich” command do? (Solaris, AIX, Linux)
A: # Will display NIS server to which client is connected to and which NIS Server is master for particular map specified with this command

Q: which command would you use to create an OS user on Solaris and Linux?
A: Linux # useradd and Solaris #useradd

Q: Which file contains passwords for local users on Solaris, Linux and on AIX?
A: Linux #/etc/shadow and Solaris # /etc/shadow

Q: Which command would you use to list partitions on Linux?
A: Linux # mount –l or # df -kh

Q: Which command/commands would you use to manage installed packages on RedHat Linux?
A: Linux # rpm

Q: What is the default port for SSH server?
A: 22

Q: Which command/commands would you use to manage installed packages on Solaris?
A: #pkginfo #pkgrm # pkgadd #pkgchk

Q: What command would you use to install an OS patch on Solaris?
A: #showrev –p and #patchadd -p

Q: Which Veritas command would you use to display a list of Veritas volumes?
A: # vxprint

Q: Which Veritas command would you use to display a list of disks on a system?
A: # vxdx list

Q: What is the main system configuration utility in AIX?
A:

Q: Which file has a list of filesystems to be mounted at boot time on Solaris, Linux and AIX?
A: Linux # /etc/fstab and Solaris #/etc/vfstab

Q: Which Veritas Cluster Server command would you use to display the status of a cluster and it’s resources?
A:

Q: Which command would you use to rename a disk for VMware Guest virtual machine on ESX server 3 storage volume?
A:

Q: Which command would use on VMware ESX 3 server to display virtual switch configuration?
A:



Q: Which Veritas Cluster Server command would you use to display the status of a cluster and it’s resources?
A: clustat and to manage the cluster configruation use clusvcadm

Q: Which command would you use to rename a disk for VMware Guest virtual machine on ESX server 3 storage volume?
A: the best way is clone vm to different datastore or in the same datastore with different name
vmkfstools -i \\vmfs\old_vm.vmdk \\vmfs\new_vm.vmdk
this will take care of it all

Q: Which command would use on VMware ESX 3 server to display virtual switch configuration?
A: esxcfg-vswitch -l or user esxcfg-vswitch -help to see all options

Access common commands quicker ?ps -ef | grep -i $@
Alternative for top command ?prstat –a
Change to a directory, which is having very long name ?
cd CDMA_3X_GEN*Here original directory name is . .CDMA_3X_GENERATION_DATAnswer:.
Delete blank lines in a file ?
cat sample.txt | grep -v ?^$? > new_sample.txt
Display disk usage in Kilobytes ?
du -k
Display Ethernet Address arp table ?
arp -a
Display the all files recursively with path under current directory ?
find . -depth -print
Display the Disk Usage of file sizes under each directory in currentDirectory ?
du -k * | sort .nr (or) du .k . | sort -nr
Display the files in the directory by file size ?
ls .ltr | sort .nr .k 5
Display the inter-process communication facility status ?
Ipcs